Ticket #1065 (closed defect: worksforme)

Opened 13 years ago

Last modified 13 years ago

Kupu does not work on Internet Explorer: case 2

Reported by: hans Owned by: tarmo
Priority: blocker Milestone:
Component: generic Version:
Keywords: ie Cc:
Time planned: 1h Time remaining:
Time spent: 15m

Description (last modified by hans) (diff)

Error message is displayed before kupu is loaded:

http://lemill.org/trac/attachment/ticket/1065/defect2.jpg?format=raw

Error message:

http://lemill.org/trac/attachment/ticket/1065/defect2_error.jpg?format=raw

After clicking OK multimedia page template is loaded with kupu. Buttons in Kupu do not work but it is possible to edit HTML.

Attachments

defect2.jpg (83.4 KB) - added by hans 13 years ago.
defect2_error.jpg (49.3 KB) - added by hans 13 years ago.

Change History

Changed 13 years ago by hans

Changed 13 years ago by hans

comment:1 Changed 13 years ago by hans

  • Description modified (diff)

comment:2 Changed 13 years ago by laszlo

  • Owner changed from anonymous to laszlo
  • Status changed from new to assigned

comment:3 Changed 13 years ago by laszlo

  • Status changed from assigned to closed
  • Time spent set to 15m
  • Resolution set to worksforme
  • Time planned set to 1h

I've tested it in IE6 and IE7, and Kupu is working for me.

comment:4 Changed 13 years ago by hans

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I think we should take defect tickets more seriously. If we are not able to reproduce the same error message in 15 minutes it does not mean yet that everything is fine. I saw real users (teachers) in real environment (classroom) receiving this error message.

At least we could do some googling: http://www.google.com/search?q=exception+_SARISSA_IS_MOZ+undefined

It seems that other people get the same error message:

There is also a possible solution:

comment:5 Changed 13 years ago by tarmo

  • Keywords ie added
  • Owner changed from laszlo to tarmo
  • Status changed from reopened to new

I'll implement the solution mentioned in the previous commit.

comment:6 Changed 13 years ago by tarmo

  • Status changed from new to closed
  • Resolution set to worksforme

Ah, the fix mentioned in the comment is already done into Plone 2.5. :( So no idea how to solve this. I've checked the encoding specifications that lemill.net sends and they are all utf-8, as well as the content. This may have just been a weird combination of the Windows and IE settings that they had, and maybe some latin content thrown somewhere for the fun of it (faulty web proxy?). No idea... Unless someone can repeat this on another machine, I'm blaming the desktop machine configuration that was photographed.

comment:7 Changed 13 years ago by vahur

From my experience, kupu has shown great stability and has worked for me where it should be. as with every javascript, errors may occur when user tries to do something too soon (page isn't fully loaded, javascript couldn't initialize all variables, etc). In this case I would guess that sarissa library wasn't loaded? but it doesn't make sense becase javascript files are usually merged as one in plone.

So, I would also blame the desktop, impatient user.

Note: See TracTickets for help on using tickets.