Ticket #1066 (closed defect: worksforme)

Opened 13 years ago

Last modified 11 years ago

"Add media piece" throws ConflictError

Reported by: hans Owned by: tarmo
Priority: postponed Milestone:
Component: generic Version:
Keywords: Cc:
Time planned: Time remaining:
Time spent:

Description (last modified by hans) (diff)

Clicking "Add media piece" button on multimedia page returns error:

http://lemill.org/trac/attachment/ticket/1066/defect_add_media_piece.jpg?format=raw

Attachments

defect_add_media_piece.jpg (172.7 KB) - added by hans 13 years ago.
defect_url.JPG (29.4 KB) - added by hans 13 years ago.
defect_message.JPG (112.2 KB) - added by hans 13 years ago.

Change History

Changed 13 years ago by hans

comment:1 Changed 13 years ago by hans

  • Description modified (diff)

comment:2 Changed 13 years ago by jukka

Database conflict error seems really.. deep. LeMill's error log shows that there were one ReadConflictError? at 11:42:23 and then 11:58:57 ConflictError?, 12:04:27 ConflictError?, 12:04:34 ConflictError?, 12:04:33 ConflictError?, each for different user.

And here's traceback for that error.

   - <FSControllerPythonScript at /lemill-server/content_edit used for /lemill-server/content/portal_factory/MultimediaMaterial/multimediamaterial.2007-01-05.2074077873>
   - Line 1
  Module Products.CMFCore.FSPythonScript, line 108, in __call__
  Module Shared.DC.Scripts.Bindings, line 311, in __call__
  Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
  Module Products.CMFCore.FSPythonScript, line 164, in _exec
  Module None, line 11, in content_edit_impl
   - <FSPythonScript at /lemill-server/content_edit_impl used for /lemill-server/content/portal_factory/MultimediaMaterial/multimediamaterial.2007-01-05.2074077873>
   - Line 11
  Module Products.Archetypes.BaseObject, line 646, in processForm
  Module Products.Archetypes.BaseObject, line 746, in _renameAfterCreation
  Module transaction._manager, line 90, in savepoint
  Module transaction._transaction, line 297, in savepoint
  Module transaction._transaction, line 294, in savepoint
  Module transaction._transaction, line 657, in __init__
  Module ZODB.Connection, line 1032, in savepoint
  Module ZODB.Connection, line 495, in _commit
ConflictError: database conflict error (oid 0xb4e0, class Products.LeMill.SectionFolder.ContentFolder)

I tried to recreate that in LeMill.net, but couldn't so it seems that something in database got temporarily very messed up. Of course it is bad if it happens again and if it's caused by multiple users doing stuff. Hans, can you tell us what exactly were you doing and was there something weird that could have caused Zope to freak out? For example, if all tried to log in with same account from different machines or all tried to upload same picture or something? btw, nice screenshot :)

comment:3 Changed 13 years ago by hans

I was logged in only from that computer. It happened during a teacher training - about 15 teachers were using the system at the same time.

The tasks were:

  • Join LeMill
  • Fill up user profile
  • Add a media piece (photo)
  • Create multimedia page that has a block of text and the photo that was uploaded in previous step. This error message came affer clicking on "Add media piece" button for the first time.

During teacher training I don't have time for screenshots, so you can expect more photo screenshots soon :)

Changed 13 years ago by hans

Changed 13 years ago by hans

comment:4 Changed 13 years ago by hans

Today I received exactly the same error doing exactly the same action on Toolbox.

URL:

http://lemill.org/trac/attachment/ticket/1066/defect_url.JPG?format=raw

Message:

http://lemill.org/trac/attachment/ticket/1066/defect_message.JPG?format=raw

comment:5 Changed 13 years ago by tarmo

  • Owner changed from anonymous to tarmo
  • Priority changed from blocker to minor
  • Status changed from new to assigned
  • Summary changed from "Add media piece" returns error message to "Add media piece" throws ConflictError

Some Plones use locking to prevent similar problems - people lock an object before editing, and release after editing. Won't work here, too complex and people would forget to release the locks. We need to keep our eyes open for future occurences and figure out a solution if they become a common problem.

comment:6 Changed 12 years ago by tarmo

  • Priority changed from minor to postponed

comment:7 Changed 11 years ago by tarmo

  • Status changed from assigned to closed
  • Resolution set to worksforme

This is obsolete.

Note: See TracTickets for help on using tickets.