Ticket #1105 (closed defect: fixed)

Opened 13 years ago

Last modified 13 years ago

Anonymous user can't see some user profiles

Reported by: hans Owned by: jukka
Priority: critical Milestone:
Component: generic Version:
Keywords: Cc:
Time planned: Time remaining:
Time spent:

Description (last modified by hans) (diff)

Anonymous user can't see some user profiles. The following profiles (and probably some others too) require login:

All these users are from Estonia and I haven't noticed them in LeMill before. They have joined very recently, it is possible that after upgrade to 1.6.

Change History

comment:1 Changed 13 years ago by pjotr

I have tried to add the member to the portal and did that from "Manage interface" into "acl_users".

The result was that I have received the same error message, but as soon as I have logged in with that user and went to the personal information edit form and saved it - the situation seemed to be resolved.

comment:2 Changed 13 years ago by tarmo

It is possible that they do not have they personal areas created yet. This means that trying to access those areas will attempt to create them, but if you're someone else, you're not allowed to. It's a problem caused by the complexity of having to support SSO (external authentication). We should probably add a method to check whether a user has his member area and if not, disable the link.

comment:3 Changed 13 years ago by hans

  • Description modified (diff)
  • Summary changed from Anonymous use can't see some user profiles to Anonymous user can't see some user profiles

comment:4 Changed 13 years ago by pjotr

I've registered myself in the normal way and the result was like that:

  1. Until I log in my user folder is not created - if someone is trying to request that: they will just see the message about the thing does not exist in the portal.
  1. As soon as I log in - the member folder is created and is nicely visible to me, but anonymous users are asked to log in.
  1. As soon as I go to the personal information form and just save it - everything is ok.

comment:5 Changed 13 years ago by jukka

  • Owner changed from anonymous to jukka
  • Status changed from new to assigned

comment:6 Changed 13 years ago by pjotr

member_view.pt -> lines 115 and 116.

These methods are call other ones, that are trying to create these subfolders - with no luck as the Unauthorized can not do that.

comment:7 Changed 13 years ago by pjotr

(In [1325]) References #1105, must be nice but try to give it a test anyway

comment:8 Changed 13 years ago by jukka

  • Status changed from assigned to closed
  • Resolution set to fixed

Seems to be working.

Note: See TracTickets for help on using tickets.