Ticket #1106 (closed defect: fixed)

Opened 13 years ago

Last modified 11 years ago

Empty pieces are displayed in a learning resource

Reported by: hans Owned by:
Priority: major Milestone:
Component: generic Version:
Keywords: Cc:
Time planned: Time remaining:
Time spent:

Description (last modified by hans) (diff)

Empty pieces are displayed in the following learning resource. Also cover image is not displayed: http://lemill.net/content/kanada-majandus/view

http://lemill.org/trac/attachment/ticket/1106/defect_empty_pieces.png?format=raw

Attachments

defect_empty_pieces.png (52.5 KB) - added by hans 13 years ago.

Change History

Changed 13 years ago by hans

comment:1 Changed 13 years ago by hans

  • Description modified (diff)

comment:2 Changed 13 years ago by laszlo

How should I reproduce it? Can you add empty media pieces?

comment:3 Changed 13 years ago by pjotr

This one is really easy to reproduce.

  1. Create a presentation.
  2. Just save it without making any changes.

This one gives us five slides created by default - none of them has pictures or texts yet.

What is the proposal to do about that?

At the moment it behaves like that: if no image is provided, then there will be nothing to show.

comment:4 Changed 13 years ago by hans

I think that we should remove empty text blocks or media pieces when saving the document. Currently it is also possible to have empty text blocks in the multimedia page...

comment:5 Changed 13 years ago by pjotr

  • Owner changed from anonymous to pjotr
  • Status changed from new to assigned

comment:6 Changed 13 years ago by pjotr

I've given that one a try and I suppose we'll be able to get rid of empty slides and stuff.

But I've found one interesting thing: if the last slide is deleted from the PresentationMaterial? - it will produce an ERROR as I suppose presentation materials are not supposed to be empty (same might happen to the MultimediaPage's).

So we should think of some some system that will cover all of this.

comment:7 Changed 13 years ago by pjotr

(In [1510]) References #1106, now if the last slide is deleted a new clean one is put there, totally empty presentations gave errors

comment:8 Changed 12 years ago by pjotr

  • Owner pjotr deleted
  • Status changed from assigned to new

setting this one free ... as I don't know any good solution

comment:9 Changed 12 years ago by pjotr

I think that user must have a right to leave some stuff empty - like empty slides in presentations. Because he might not have the idea yet and might want to add some texts/images later.

If some stuff will just get deleted - it might really be confusing to a user (Because he might have created these empty slides for or anything else for a reason - and they have just disappeared).

Hans, what's your idea?

comment:10 Changed 12 years ago by hans

Pjotr, I do not agree with that: "I think that user must have a right to leave some stuff empty - like empty slides in presentations. Because he might not have the idea yet and might want to add some texts/images later."

I still think that empty slide placeholders should be removed when the presentation is saved. People create presentation in their Powerpoint (Impress, Keynote) and upload it to LeMill when it is ready.

If it is fixed then this ticket can be closed. Laszlo has deleted that presentation and I haven't noticed that defect anywhere else. If I will see it again, then I will reopen that ticket.

comment:11 Changed 12 years ago by pjotr

I've tried creating a presentation and just leaving it empty. It does not look so bad. Plus the picture provided does not have a coverImage or even a default image. So this presentation might have just been modified by some change in the past.

Hans, try this one out and see the result. I suppose this ticket might not be relevant any more.

comment:12 Changed 11 years ago by pjotr

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.