Ticket #1158 (closed story: duplicate)

Opened 13 years ago

Last modified 13 years ago

LeMill should support wav files

Reported by: laszlo Owned by: teemu
Priority: major Milestone:
Component: generic Version:
Keywords: Cc:
Time planned: Time remaining:
Time spent:

Description

Most of the mobile devices support only wav encoding for record audio. For this reason, LeMill should support wav upload to support LeMill audio capture function.

Change History

comment:1 Changed 13 years ago by pjotr

In that case we should add all kind of variants of WAV mimetypes to the MIMITYPE_WHITELIST.

I've found several variants: audio/wav, audio/x-wav, audio/x-ms-wav, audio/wave

Or some of the files might not be addable.

comment:2 Changed 13 years ago by tarmo

A bigger problem is that our embedded players and Flash players only work with mp3. This means we'll need a whole pipeline on the server to transcode whatever audio (and video) formats to the formats that we can display.

comment:3 Changed 13 years ago by laszlo

In this case, the ticket has changed to "LeMill should support audio/video trenscoding".

comment:4 Changed 13 years ago by teemu

  • Owner changed from anonymous to teemu
  • Status changed from new to assigned

Let's make LeMill to support wav.

comment:5 Changed 13 years ago by tarmo

Does this mean that PILOTs should also accept wav format audio? Because our current flash player does not.

comment:6 Changed 13 years ago by hans

We should support ONLY those media files that can be played inside web browser (that is in some Flash-based player). I haven't found a Flash player that supports other formats than mp3.

There is already a story about converting uploaded audio files (WAV, OGG, etc) to MP3. I think it might be possible with PyMedia: #1048

Should we close this ticket as a duplicate of #1048 ?

comment:7 Changed 13 years ago by laszlo

I think yes, you can close it.

comment:8 Changed 13 years ago by tarmo

  • Status changed from assigned to closed
  • Resolution set to duplicate

Duplicate of #1158.

comment:9 Changed 13 years ago by hans

Actually, it's duplicate of #1048

Note: See TracTickets for help on using tickets.