Ticket #1514 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Members name cloud gives random results

Reported by: hans Owned by: jukka
Priority: critical Milestone:
Component: generic Version:
Keywords: Cc:
Time planned: Time remaining: 0h
Time spent:

Description (last modified by hans) (diff)

Members name cloud gives random results. http://lemill.net/community/smalvik has not done anything and her name is displayed bigger than my name.

<span class="size4">
<a href="http://lemill.net/community/Hans">Hans Põldoja</a>
</span>

<span class="size5">
<a href="http://lemill.net/community/smalvik">Sille Malvik</a>
</span>

(bigger size means bigger font)

span.size4 { font-size: 110%; line-height: 110%; }
span.size5 { font-size: 120%; line-height: 120%; }

Teimuraz Khundadze ( http://lemill.net/community/temo ) who should be our most active user is not at all in the name cloud.

http://lemill.org/trac/attachment/ticket/1514/members_name_cloud.png?format=raw

Attachments

members_name_cloud.png (150.3 KB) - added by hans 12 years ago.

Change History

Changed 12 years ago by hans

comment:1 Changed 12 years ago by hans

  • Description modified (diff)

comment:2 Changed 12 years ago by gabor

  • Owner changed from anonymous to gabor
  • Status changed from new to assigned

comment:3 Changed 12 years ago by gabor

Well, the source of this problem is probably that Sille's score wasn't updated, so she had 81. After calling the recalculateScore method the score dropped to 1, which should have fixed the problem but no, it's still size5.

Currently this is the code that calculates size from score and it should return 1 instead of 5 now:

b=int((8*log(b,2))/log(maxscore,2)) if b==0:

b=1

comment:4 Changed 12 years ago by gabor

We've discussed the issue with Pjotr, Tarmo and Jukka and the problem is that in the catalog the scores do not get updated. We might have to reindex the catalog periodically to fix these kind of issues.

comment:5 Changed 12 years ago by gabor

  • Owner gabor deleted
  • Status changed from assigned to new

comment:6 Changed 12 years ago by jukka

  • Owner set to jukka
  • Status changed from new to assigned

comment:7 Changed 12 years ago by jukka

Something is definitely wrong with recalculateScore -- it doesn't get called during the edit cycle. I tried getScore for katrina (ksilfvas), and got 12, then did recalculateScore and tried getScore again and got 802!

comment:8 Changed 12 years ago by jukka

  • Status changed from assigned to closed
  • Resolution set to fixed
  • Time remaining set to 0h

(In [2379]) Fixed #1514, for some reason catalog searches using queryCatalog gave zero results when call came from different folder and so people got smaller scores than they should.

Note: See TracTickets for help on using tickets.