Ticket #1565 (closed defect: worksforme)

Opened 12 years ago

Last modified 12 years ago

Translations can be published only by the user who made the original version

Reported by: hans Owned by: jukka
Priority: critical Milestone:
Component: generic Version:
Keywords: Cc:
Time planned: Time remaining:
Time spent:

Description

Translations can be published only by the user who made the original version. I made a translation of http://lemill.net/content/overview-of-lemill/ , but I don't have rights to publish or delete that: http://lemill.net/content/ulevaade-lemill-keskkonnast

User who created the translation should have all rights for publishing and deleting the translation.

Change History

comment:1 Changed 12 years ago by pjotr

I've been able to do that.

comment:2 Changed 12 years ago by jukka

  • Owner changed from anonymous to jukka
  • Status changed from new to assigned

comment:3 Changed 12 years ago by jukka

  • Status changed from assigned to closed
  • Resolution set to worksforme

I couldn't reproduce the error.

But it is confusing when there is a halfway done draft translation and I want to complete it, but I cannot get it published -- and because it is draft, I cannot see who could publish it. Of course you can find that from history, but I think this is bit too complicated. I think this gets fixed with private drafts.

Note: See TracTickets for help on using tickets.