Ticket #1566 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Deleting learning resource returns an error

Reported by: hans Owned by: anonymous
Priority: blocker Milestone:
Component: generic Version:
Keywords: Cc:
Time planned: Time remaining: 0h
Time spent:

Description

Deleting learning resource http://lemill.net/content/google-maps-test/delete returns an error:

Site error
This site encountered an error trying to fulfill your request. The errors were:

Error Type
CatalogError
Error Value
The object unique id must be a string.
Request made at
2007/10/17 12:55:44.491 GMT+3

Change History

comment:1 Changed 12 years ago by gabor

I've accidentally changed this content on lemill.net when fixed the google maps problem in #1545 so I made I restored Hans' version. Maybe that is the thing that causes the problem.

comment:2 Changed 12 years ago by jukka

  • Status changed from new to closed
  • Resolution set to fixed
  • Time remaining set to 0h

(In [2100]) Fixed #1566, I hope. Couldn't replicate the error but removed some effective date / expiration date related code that was causing it.

comment:3 Changed 12 years ago by hans

  • Status changed from closed to reopened
  • Resolution fixed deleted

It seems that it's not fixed. I still get error when I try to delete this resource:

Site error

This site encountered an error trying to fulfill your request. The errors were:

Error Type
    CatalogError
Error Value
    The object unique id must be a string.
Request made at
    2008/01/02 14:49:59.041 GMT+2

comment:4 Changed 12 years ago by tarmo

  • Status changed from reopened to closed
  • Resolution set to fixed

We haven't updated LeMill.net after that fix.

comment:5 Changed 12 years ago by hans

  • Status changed from closed to reopened
  • Resolution fixed deleted

Now you have definitely updated lemill.net, but the defect is still there.

Site error
This site encountered an error trying to fulfill your request. The errors were:

Error Type
    CatalogError
Error Value
    The object unique id must be a string.
Request made at
    2008/01/23 12:04:23.266 GMT+2

comment:6 Changed 12 years ago by pjotr

Someone should check what Module/Method? is producing this. Also check the UID of that item, there might be something fishy about that one.

I can not reproduce that on my system. It might be due to something inside that object data. I can not check that as I don't have manager/administrator permission in lemill.net.

comment:7 Changed 12 years ago by jukka

Problematic part is here. Since we now have our own workflow_tool, I think I can go and make reindexWorkflowVariables more failproof.

Module None, line 4, in script_deleteResource
<FSControllerPythonScript at /lemill-server/script_deleteResource used for /lemill-server/content/google-maps-test>
Line 4
Module Products.LeMill.Resources, line 534, in deleteResource
Module Products.CMFFormController.FSControllerPythonScript, line 104, in __call__
Module Products.CMFFormController.Script, line 145, in __call__
Module Products.CMFCore.FSPythonScript, line 108, in __call__
Module Shared.DC.Scripts.Bindings, line 311, in __call__
Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
Module Products.CMFCore.FSPythonScript, line 164, in _exec
Module None, line 26, in content_status_modify
<FSControllerPythonScript at /lemill-server/content_status_modify used for /lemill-server/content/google-maps-test>
Line 26
Module Products.CMFCore.WorkflowTool, line 302, in doActionFor
Module Products.CMFCore.WorkflowTool, line 638, in _invokeWithNotification
Module Products.CMFCore.WorkflowTool, line 701, in _reindexWorkflowVariables
Module Products.Archetypes.CatalogMultiplex, line 119, in reindexObject
Module Products.CMFPlone.CatalogTool, line 357, in catalog_object
Module Products.ZCatalog.ZCatalog, line 564, in catalog_object
CatalogError: The object unique id must be a string.

comment:8 Changed 12 years ago by jukka

  • Status changed from reopened to closed
  • Resolution set to fixed

(In [2377]) Fixed #1566. Still not sure what to do with these bad catalog results and where they come from.

comment:9 Changed 11 years ago by hans

I was finally able to delete this resource now.

Note: See TracTickets for help on using tickets.