Ticket #508 (closed story: duplicate)

Opened 13 years ago

Last modified 13 years ago

Pieces do not have language

Reported by: hans Owned by: teemu
Priority: major Milestone:
Component: generic Version:
Keywords: Cc:
Time planned: Time remaining:
Time spent:

Description

My experience with lemill.net shows that people are using people are choosing the language of the piece in very different ways:

  • most of users mark pieces as "Language neutral"
  • some users choose the language of title and descrription as language for the piece
  • if language is relevant for the content of the piece (photo of some text document, audio or video recording with some talk) people will probably choose tha language of the content

I think that the third case is going to be quite rare.

I suggest that we should remove language for pieces, because:

  • people have difficulties in choosing the language
  • language becomes important when piece is added to some template. For example when sound file of some speech is added to the template together with short summary of the speech.
  • this will help to differentiate between pieces and materials (#435)
  • this will make publishing a piece easier

People should choose the language for title and description just as they want. If I want to publish photo some historical place in Estonia that is important only locally I will put the title and description in Estonian. If I will publish a photo from Vatican I will put title and description in English because it is important for teachers in various countries.

For example del.icio.us works fine with titles, tags and descriptions in various languages. There is now way to choose language for the link, although some people would say that they could also have language metadata of the URL :)

Change History

comment:1 Changed 13 years ago by hans

It is currently in conflict with #507 and needs further discussion.

comment:2 Changed 13 years ago by tarmo

  • Milestone 0.6 Ambiorix deleted

comment:3 Changed 13 years ago by teemu

  • Owner changed from anonymous to teemu
  • Status changed from new to assigned

Hans change the #507 to be consistent with this decision. Ok for me.

comment:4 Changed 13 years ago by hans

  • Status changed from assigned to closed
  • Resolution set to duplicate

Closed as a duplicate of #507.

Note: See TracTickets for help on using tickets.